How to Solve For W164 Front Sam Offline Programming With Using MB SD C4 And Xentry V2015.12

On Feb,29th, one of obd2shop.co.uk customer email to us he has a question that no option to program the SAM using offline programming with SD C4 multiplexer and Xentry 12/2015 fail to do.  How can we solve this if you also happend this problem ? Following with us, here is the way help you:

Customer testing vehicle and using tool:

2005 ML350 4Matic

SD C4 multiplexer and Xentry 12/2015

Problems Description:
Problem one: Problem with the front SAM, when select Yes the next screen goes to online programming. There is no option to program the SAM using offline programming. At least I couldn’t find it. The starter doesn’t even crank.

Problem two: Secondary problem is the ISM. The original module generated a message on display: “Drive to workshop without changing gear”. The transmission now is stuck in Park. I installed another identical module from another ML350 and the message is gone but there is no reaction when changing the shifter from park to other positions. I get a message to depress the brake even when the brake pedal is depressed.
Also, when I go to the Developer option I get the message the file is missing, see photo. So, I have two serious problems to deal with. I’m looking forward to your feedback.

sd-c4-w164-1

sd-c4-w164-2

sd-c4-w164-3

Obd2shop.co.uk Engineers reply and solution way:

Please can not use ISM from other car,..use brand new,..marry it to the vehicle and you will probably start the engine.
Then program front sam online,..or if you dont have online access,..pass this step,..it has program inside it generally.///code it manually according your car,..and if still has SAM errors,..probably could change it with new one!
Neither ISM neither SAM need online or offline,..they always can be initially startup manually with DAS

As for the question “I don’t know why when I accessed the front SAM with DAS it gave me a message saying that the SAM needs to be programmed. See the attached photos. It is not my imagination. This is what I got when trying to read the fault codes from the front SAM.”
I guess: probably your sam is almost dead.//put other one used..or new one

Hope it would help you

(Visited 135 times, 1 visits today)